ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 12 years ago

Closed 10 years ago

#1026 closed defect (wontfix)

ver2.8.xグレードアップ時、ブログの読み込み・登録が出来なくなる

Reported by: hondaboo Owned by: nobody
Priority: minor Milestone:
Component: user【ユーザー向け機能】 Version: 2.6.x & 2.8.x & 2.10.x
Keywords: 再現待ち Cc:

Description (last modified by ashida)

http://sns.openpne.jp/?m=pc&a=page_fh_diary&target_c_diary_id=12049より転載

設定変更の画面で、 「BlogのURL」にブログのURLを入れて変更ボタンを押すと、
「BlogのURLが無効です」とエラーメッセージが表示されてBlogを登録できません。

ver1.8.7からver2.8.1にグレードアップした環境なのですが、
そういえばグレードアップしたあとから、マイホームに最新のBlogが表示されなくなったのですが、
それも関係するのでしょうか?

 ちなみにcrontabは以下のようになっています。

SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=root
HOME=/

# run-parts
01 * * * * root run-parts /etc/cron.hourly
02 4 * * * root run-parts /etc/cron.daily
22 4 * * 0 root run-parts /etc/cron.weekly
42 4 1 * * root run-parts /etc/cron.monthly

# 6時にメールを送信&20分毎にRSS更新
00 6 * * * root sh /var/www/OpenPNE/bin/tool_send_dairy_news.cron
 /var/www/OpenPNE/bin/ /usr/bin/php
00 6 * * * root sh /var/www/OpenPNE/bin/tool_send_birthday_mail.cron 
/var/www/OpenPNE/bin/ /usr/bin/php
00 6 * * * root sh /var/www/OpenPNE/bin/tool_send_schedule_mail.cron 
/var/www/OpenPNE/bin/ /usr/bin/php
*/20 * * * * root sh /var/www/OpenPNE/bin/tool_rss_cache.cron 
/var/www/OpenPNE/bin/ /usr/bin/php

Change History (8)

comment:1 Changed 12 years ago by hondaboo

http://openpne.jp/?m=pc&a=page_fh_diary&target_c_diary_id=12229 にて、2.8.2へのバージョンアップでも似た症状が報告されています。

2.8.2にバージョンアップしたら外部のBlogが取り込めなくなった
	
	
		
会社のOpenPNEを、2.6.6.2から2.8.2にバージョンアップした。
特に問題ないと思ったのだが、外部のBlogが取り込めなくなっていることに気付いた。
「設定変更」で社外のBlogのURLを指定すると、エラーではじかれてしまうのだ。

社内なのでProxyを経由しないといけないので、Snoopy.class.phpをここを見て変更している。
http://shigememo.seesaa.net/article/32036288.html

2.6.6.2の時は、Snoopy.class.phpの変更だけでProxy経由でも問題なく取得できていた。
2.8.2では、Snoopy.class.phpの他に変更する箇所があるのだろうか?

comment:2 Changed 12 years ago by kiwa

Priority: minorcritical
Summary: BlogのURLが無効ですver1.8.7→ver2.8.1グレードアップ時、ブログの読み込み・登録が出来なくなる

テストする環境がないため、判断をお願いします。

comment:3 Changed 12 years ago by kiwa

Summary: ver1.8.7→ver2.8.1グレードアップ時、ブログの読み込み・登録が出来なくなるver2.8.xグレードアップ時、ブログの読み込み・登録が出来なくなる

comment:4 Changed 12 years ago by kiwa

Owner: changed from nobody to ogawa

reassign忘れてました

comment:5 Changed 12 years ago by ogawa

Owner: changed from ogawa to nobody

2.8からは外部ブログ取得用のライブラリが変更になっていますので、改変して使っている場合は他の箇所も確認する必要があるかもしれません。

comment:6 Changed 12 years ago by kiwa

Priority: criticalminor

バグではないようなのでプライオリティ下げます

comment:7 Changed 11 years ago by ashida

Description: modified (diff)

comment:8 Changed 10 years ago by nakasone

Resolution: wontfix
Status: newclosed

記事、バージョンが古いためチケットを閉じます。

Note: See TracTickets for help on using tickets.