ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 11 years ago

Last modified 10 years ago

#1490 new defect

転送メールが途中で切れてしまう

Reported by: kiwa Owned by: nobody
Priority: critical Milestone:
Component: その他 Version:
Keywords: 再現待ち 開発チーム確認 Cc:

Description (last modified by kiwa)

http://sns.openpne.jp/?m=pc&a=page_c_topic_detail&target_c_commu_topic_id=2788 より転記

お世話になっております。
始めて質問させて頂きます。

現在、私が運営しているSNSでコミュニティの書き込みを
PC/携帯にメール転送した場合に、メール本文が途中で
切れてしまうといった症状が出ています。

原因は特定出来ていまして、MS外字というのでしょうか
「①②」といった丸数字や「㈱」といった外字が有った場合に
その文字の前の部分でメールが切れて転送されてしまいます。

利用サーバは エックスサーバ
OpenPNEのバージョンは v2.6.11 を利用しています。

何か設定等で直す方法が有れば教えて頂けますでしょうか?

よろしくお願い致します。

同現象:#1852

Change History (13)

comment:1 Changed 11 years ago by kiwa

Component: pne-adminpne-framework

comment:2 Changed 11 years ago by kiwa

Priority: minorcritical

comment:3 Changed 11 years ago by imoto

Keywords: 再現せず added; 再現待ち removed

特殊文字は省略されますが、メールが途中で切れるというバグは再現できませんでした。

■メール文

原因は特定出来ていまして、MS外字というのでしょうか
「①②」といった丸数字や「㈱」といった外字が有った場合に
その文字の前の部分でメールが切れて転送されてしまいます。

■結果 PC

原因は特定出来ていまして、MS外字というのでしょうか
「」といった丸数字や「」といった外字が有った場合に
その文字の前の部分でメールが切れて転送されてしまいます。

携帯(softbank911T)

原因は特定出来ていまして、MS外字というのでしょうか
「」といった丸数字や「」といった外字が有った場合に
その文字の前の部分でメールが切れて転送されてしまいます。

comment:4 Changed 11 years ago by kiwa

Owner: changed from nobody to ebihara

開発チームで再度確認をお願いしたいです。

comment:5 Changed 11 years ago by ebihara

Keywords: 再現待ち added; 再現せず removed
Status: newassigned

検証してみます

comment:6 Changed 11 years ago by ebihara

Status: assignednew

comment:7 Changed 11 years ago by kiwa

#1852に同じような報告があがっています

管理ユーザーからメール送るとID=1のユーザー名以降が表示されなくなるです。。ほかのユーザーだとちゃんと表示されるのにな。絶対おかしい。


管理画面のメール文言設定で、

「({$c_member.nickname})さんの~」({$c_member.nickname})以降がなぜか真っ白になって表示されない…。今までこんなことなかったのに。。

一応2.10バージョン全部試したのですが改善されず。くそっ!

だとするとデータベースでおかしなことが起こってるのかな?

㈱という文字を使用しているそうです

comment:8 Changed 11 years ago by kiwa

Description: modified (diff)

comment:9 Changed 11 years ago by ebihara

Status: newassigned

確認します。

comment:10 Changed 11 years ago by ebihara

やはり再現できませんでした。

  • PHPのバージョンによる問題
  • mbstringの設定による問題
  • MTAによる問題

が考えられるかもしれません。

エックスサーバと同じ PHP5.1.6 環境でチェックしましたが、PHP4も使用できるということなので、PHP4環境で再度検証してみます。

comment:11 Changed 11 years ago by ebihara

PHP4環境においても再現できませんでした。単純にPHPのバージョンの問題というわけではなさそうです。

となると mbstring の設定などが怪しいところですが、この辺はエックスサーバで実際に検証してみる必要がありそうです。

comment:12 Changed 11 years ago by ogawa

Version: 2.8.x & 2.10.x & 2.11.x

comment:13 Changed 10 years ago by kiwa

Keywords: 開発チーム確認 added
Owner: changed from ebihara to nobody
Status: assignednew
Note: See TracTickets for help on using tickets.