ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 11 years ago

Closed 11 years ago

#2317 closed enhancement (fixed)

セットアップガイドの動作環境を書き換える

Reported by: ebihara Owned by: ebihara
Priority: critical Milestone: OpenPNE2.12beta1
Component: 指定しない Version:
Keywords: Cc:

Description

セットアップガイドの動作環境が古いまま・大雑把なので書き換える。

Change History (8)

comment:1 Changed 11 years ago by ebihara

Owner: changed from nobody to ebihara
Status: newassigned

OpenPNEが依存しているライブラリが明示している動作環境のうち、PHPに関する部分を洗い出してみました。

  • PEAR::Auth : PHP 4.3.3 or newer
  • PEAR::Services_Amazon : PHP 4.0.0 or newer
  • PEAR::DB : PHP 4.2.0 or newer
  • PEAR::Mail_mimeDecode : PHP 4.3.0 or newer
  • PEAR::Net_IPv4 : (none)
  • PEAR::XML_Serializer : PHP 4.2.0 or newer (PHP Extension: xml)
  • PEAR::XML_RPC : PHP 4.2.0 or newer(PHP Extension: xml)
  • PEAR::Log : PHP 4.3.0 or newer
  • PEAR::Date : PHP 4.3 or newer
  • PEAR::Calendar : PHP 4.0.5 or newer
  • PEAR::Cache_Lite : PHP 4.0.0 or newer
  • PEAR::Cache : (none)
  • SimplePie? : PHP 4.3 or higher (including PHP 5), PHP's XML extension, PHP's PCRE extension
  • KCAPTCHA : PHP 4.0.6+, GD
  • Snoopy : (none)
  • Smarty : PHP 4.0.6 or greater
  • PHP OpenID : from 4.3.0 and up (Yadis は PHP OpenID のものを使っているのでこれと同様)
  • Etags : (none)

ということで、

  • とりあえず PHP4.3.3 が最低動作保証バージョンとなる
  • xml extension と pcre extension は必須

となりそうです。

comment:2 Changed 11 years ago by ebihara

OpenPNE_Validator などの正規表現で u 修飾子を使用しているので、

  • PCRE_UTF8 support

が必要になります。

comment:3 Changed 11 years ago by ebihara

PHP の ChangeLog から判断できる限りにおいては、 PHP4.3.3 以降の機能追加・改善に依存している箇所はなく、PHP4.3.3以降を動作保証しても問題はないように見受けられます。

comment:4 Changed 11 years ago by ebihara

CentOSにおけるPHPの対応状況ですが、

http://wiki.centos.org/FAQ/CentOS5#head-8b85501ca7f023bc0eeb0fef98143e10fb6adefc

11. Is PHP 5.2.5 released for CentOS?

Short answer: No.

A bit longer answer: No. As with each other program in CentOS, the version numbers of released software will not change over the life time of a CentOS product. CentOS 5.0 contained PHP 5.1.6, and that is the point version PHP will stay at for the life time of CentOS 5. It is possible that upstream or the CentOS team decides to push a newer version into some additionial repository. But there are no such plans at the moment.

とのことなので、PHP5系については、PHP5.0.x および PHP5.1.x を動作環境としたいと思います。

comment:5 Changed 11 years ago by ebihara

以上の調査結果から、PHPの動作環境を以下のように定めたいと思います。

  • PHP 4.3.3 以降 / 5.0.x / 5.1.x
    • PHP の mbstring 拡張モジュールを使用可能
    • PHP の XML 拡張モジュールを使用可能
    • PHP の PCRE 拡張モジュールを使用可能 (UTF-8サポート)
    • PHP から GD ライブラリを使用可能 (JPEG/GIF/PNG サポート)
    • PHP の mcrypt 拡張モジュールの使用を推奨

comment:6 Changed 11 years ago by ebihara

PHPで書かれた他のオープンソースのマニュアルを見て回りましたが、Webサーバについては特に指定がないですね。 PHP自身も特に明記していないようです。

そこでWebサーバについては、特段変更しません。mod_rewrite を推奨する旨は書き加えてもいいかと思いますが、今後のOpenPNEの状況を見てからでもよいかなという印象です。

comment:7 Changed 11 years ago by ebihara

Keywords: 確認中 added

r6836, r6837 で PHP の動作環境についての記述を書き換えました。

これでとりあえずは充分である気がします。

ご確認ください。

comment:8 Changed 11 years ago by ebihara

Keywords: 確認中 removed
Resolution: fixed
Status: assignedclosed

OKっぽいですな

Note: See TracTickets for help on using tickets.