ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 11 years ago

Closed 11 years ago

#3179 closed defect (invalid)

携帯から新規登録が出来ない

Reported by: imamura623 Owned by: kiwa
Priority: minor Milestone:
Component: 指定しない Version:
Keywords: 再現待ち Cc:

Description

http://sns.openpne.jp/?m=pc&a=page_c_topic_detail&target_c_commu_topic_id=4189より転記

お世話になります。
現在OpenPNE-2.12.5を使用しております。

同様のトピックも確認させて頂いたのですが、解決できなかったので再度トピックを作らせてください・・・

サーバは「VPS使えるネットシルバープラン」
https://www.tsukaeru.net/plans/vps/detail.php
です。

問題点は携帯から新規登録を行おうとすると、エラーメールが帰ってきてしまうことです。

①最初に行いましたのは、

PLESKのメールプリファレンスにて、「テキストつきで返信します」の設定を行い、

/var/qmail/mailnames/ドメイン.com/の.qmail-defaultを下記のように修正致しました。

#|bouncesaying This\ address\ no\ longer\ accepts\ mail.
|/usr/bin/php -q /var/www/vhosts/ドメイン.com/httpdocs/OpenPNE/bin/mail.php

これでドメイン.com宛のメールは全て、mail.phpを通すことになるということのようですが、get@ドメイン.comに新規登録を行おうと空メールを送ると下記のようなエラーメールが帰ってきます。

///メールの内容
Hi. This is the qmail-send program at ドメイン.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<ドメイン.com>:
Could not open input file: /var/www/vhosts/ドメイン.com/httpdocs/OpenPNE/bin/mail.php

--- Below this line is a copy of the message.

Return-Path: <******@docomo.ne.jp>
Received: (qmail 17932 invoked from network); 23 Nov 2008 15:27:11 +0900
Received: from mail127.docomo.ne.jp (HELO docomo.ne.jp) (203.138.203.201)
by ドメイン.com with SMTP; 23 Nov 2008 15:27:10 +0900
Date: Sun, 23 Nov 2008 15:27:09 +0900 (JST)
From: ******@docomo.ne.jp
To: get@ドメイン.com
Subject:
Message-ID: <IMTy1XNE104986660fbM@docomo.ne.jp>
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-2022-jp"
Content-Transfer-Encoding: 7bit
///

この内容はqmailはちゃんと動いており、qmail-defaultも反映はしているが、mail.phpが開けないという解釈で宜しいのでしょうか・・・

ちなみにmail.phpのパーミッションも755にしてありますし、mail.phpのデバックを行いましたが、当然中身は何も触っていないのでNo syntax errorsです。

他のトピックで見たところ、httpdocsフォルダのパーミッションは755でないと、mail.phpが動かないと書いてありましたのでそのように修正を行ったところ、今度はエラーメールすら帰ってこなくなりました。

そこで、このhttpdocsが755の状態で、qmailが動いているか/usr/local/psa/var/log/maillogを確認したところ、

///
Nov 23 15:55:12 ドメイン relaylock: /var/qmail/bin/relaylock: mail from 203.138.203.198:27331
(mail124.docomo.ne.jp)
Nov 23 15:55:13 ドメイン qmail-queue[32438]: mail: all addreses are uncheckable - need to skip
scanning (by deny mode)
Nov 23 15:55:13 ドメイン qmail-queue[32438]: scan: the message(drweb.tmp.vDQAE3) sent by *****
*@docomo.ne.jp to get@ドメイン.com should be passed without checks, because contains uncheckabl
e addresses
Nov 23 15:55:13 ドメイン qmail-queue-handlers[32456]: Handlers Filter before-queue for qmail s
tarted ...
Nov 23 15:55:14 ドメイン qmail-queue-handlers[32456]: from=******@docomo.ne.jp
Nov 23 15:55:14 ドメイン qmail-queue-handlers[32456]: to=get@ドメイン.com
Nov 23 15:55:14 ドメイン qmail-queue-handlers[32456]: hook_dir = '/var/qmail//handlers/before-
queue'
Nov 23 15:55:14 ドメイン qmail-queue-handlers[32456]: recipient[3] = 'get@ドメイン.com'
Nov 23 15:55:14 ドメイン qmail-queue-handlers[32456]: handlers dir = '/var/qmail//handlers/bef
ore-queue/recipient/get@ドメイン.com'
Nov 23 15:55:19 ドメイン qmail-queue-handlers[32456]: starter: submitter[32461] exited normall
y
Nov 23 15:55:19 ドメイン qmail: 1227423319.399670 new msg 102964696
Nov 23 15:55:19 ドメイン qmail: 1227423319.399750 info msg 102964696: bytes 447 from <******@d
ocomo.ne.jp> qp 32461 uid 2020
Nov 23 15:55:20 ドメイン qmail: 1227423320.884315 starting delivery 272: msg 102964696 to loca
l 1-get@ドメイン.com
Nov 23 15:55:20 ドメイン qmail: 1227423320.884404 status: local 1/10 remote 0/20
Nov 23 15:55:20 ドメイン qmail-local-handlers[32538]: Handlers Filter before-local for qmail s
tarted ...
Nov 23 15:55:21 ドメイン qmail-local-handlers[32538]: from=******@docomo.ne.jp
Nov 23 15:55:21 ドメイン qmail-local-handlers[32538]: to=get@ドメイン.com
Nov 23 15:55:25 ドメイン qmail: 1227423325.696276 delivery 272: success: did_1+0+2/
Nov 23 15:55:25 ドメイン qmail: 1227423325.696376 status: local 0/10 remote 0/20
///

というログが表示され、特に問題なくqmailは動いているように思えます。

・・・ここでこの作業は断念致しました。

②次に他のトピックで、キャッチ転送を使うというのがありましたので、それを試しました。

メールアカウントktai@ドメイン.comを作り、PLESKのメールプリファレンスにて、

「キャッチ転送」[ktai@ドメイン.com]の設定を行い、

/var/qmail/mailnames/ドメイン.com/ktaiの.qmailを下記のように修正致しました。

| true
./Maildir/
|/usr/bin/php /var/www/vhosts/5629.jp/httpdocs/OpenPNE/bin/mail.php

結果は同じエラーメールが帰ってきます。当然といえば当然、同じ処理を別のアカウントに転送して行っているだけですよね・・・
(httpdocsが755の場合は何も帰ってきません。)
また、.qmail-defaultを最初の状態に戻し、getアカウントの.qmailを上記に変更してみたりもしましたが、結果は同じでした。

どなたか原因がわかる方がいらっしゃれば是非教えてください。
ちょっとしたヒントでも構いません・・・
宜しくお願い致します。

【参考】
本
・OpenPNEカスタマイズによるSNSサイトの構築と運営
トピック
http://sns.openpne.jp/?m=pc&a=page_c_topic_detail&target_...
他色々 

Change History (2)

comment:1 Changed 11 years ago by kiwa

Owner: changed from nobody to kiwa

バグではないようなのでこのチケットは閉じます。

comment:2 Changed 11 years ago by kiwa

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.