ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3719 closed defect (fixed)

CHECK_IMG_AUTH=true の時、ログイン前のバナー画像を表示できない

Reported by: tietew Owned by: fukamachi
Priority: minor Milestone: OpenPNE2.12.11
Component: 指定しない Version: 2.12.x
Keywords: Cc:

Description (last modified by kiwa)

■現象

config.phpでCHECK_IMG_AUTHをtrueにするとログイン前バナーが表示されない

■原因

CHECK_IMG_AUTHがtrueの場合、img.phpで処理される画像は(ファイル名がmodule_で始まるものの内の一部とスキンを除き)認証されていないと出力されないようになっている為、ログインしないで見ることのできるページ(o_で始まるページ)上では表示されない。

■修正内容

CHECK_IMG_AUTHがtrue時、管理画面のバナー設定で、ログイン前表示:× かつ ログイン後表示:○ となっているバナーのみ認証確認を行うように修正。

開発版で先行対応していた#1845の取り込み。

■関連情報

#1845 CHECK_IMG_AUTHをtrueにするとログイン前バナーが表示されない

Change History (8)

comment:1 Changed 11 years ago by tietew

対処法を考えてみたのですが、ファイル名が "b_" で始まる場合はCHECK_IMG_AUTH を無視する、みたいなアドホックなハックしか思いつきませんでした。なのでパッチは書いていません。

comment:2 Changed 11 years ago by kiwa

Keywords: 再現待ち removed
Milestone: OpenPNE2.12.11
Type: defectenhancement

#1845で開発版のみ対応されているようです。問題なければ2.12.11で取り込みましょう。

comment:3 Changed 11 years ago by fukamachi

Owner: changed from nobody to fukamachi
Status: newassigned

修正します

comment:4 Changed 11 years ago by fukamachi

Keywords: 確認中 added

r11433で修正しました。

comment:5 Changed 11 years ago by kiwa

Type: enhancementdefect

comment:6 Changed 11 years ago by nagasawa

Keywords: テスト待ち added; 確認中 removed

確認しました。

comment:7 Changed 11 years ago by nakasone

Keywords: テスト待ち removed
Resolution: fixed
Status: assignedclosed

動作確認しました。問題ありません。

comment:8 Changed 11 years ago by kiwa

Description: modified (diff)
Note: See TracTickets for help on using tickets.