ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#898 closed defect (invalid)

Yahoo!トピックスが表示されない(v2.7.4)

Reported by: motoi Owned by: nobody
Priority: minor Milestone: OpenPNE2.8.1
Component: user【ユーザー向け機能】 Version:
Keywords: Cc:

Description

http://openpne.jp/?m=pc&a=page_fh_diary&target_c_diary_id=10678より転載です↓↓

現象:
http://public.news.yahoo.co.jp/blogparts/fc/
にあるYahoo!ニューストピックスのソースコードをサイドバナーに
貼り付けてもブラウザでトピックスが表示されない。
トップバナーでは表示可能。

=====こうなって欲しいのに
<script>var CFLwidth = "150";var CFLheight = "208";var CFLswfuri = "http://i.yimg.jp/i/topics/blogparts/topics_s.swf?genre=to...";</script><script type="text/javascript" charset="euc-jp" src="http://public.news.yahoo.co.jp/blogparts/js/topics.js"></script>
======

=====こうなってしまう
<script>var CFLwidth = "150";var CFLheight = "208";var CFLswfuri = "<a href="http://i.yimg.jp/i/topics/blogparts/topics_s.swf?genre=to..." target="_blank">http://i.yimg.jp/i/topics/blogparts/topics_s.swf?genre=to...</a>";</script><script type="text/javascript" charset="euc-jp" src="<a href="http://public.news.yahoo.co.jp/blogparts/js/topics.js" target="_blank">http://public.news.yahoo.co.jp/blogparts/js/topics.js</a>"></script>
=====

環境:
OpenPNE 2.7.4(develop/開発版)

確認できた原因:
管理画面→デザイン→バナー設定→サイドバナー→ログイン後
に入力したスクリプトと実際に出力されるスクリプトが異なる。
スクリプトの途中にリンクタグが混入してしまう。

対処/対応
安定版への移行で解消できると思われる。

note:
OpenPNE 2.6.6.2(stable/安定版)では発生しないこと確認済

Change History (2)

comment:1 Changed 12 years ago by ToshihiroK

Resolution: invalid
Status: newclosed

2.8beta版で既に修正済み。

comment:2 Changed 12 years ago by ToshihiroK

Keywords: 再現待ち removed
Note: See TracTickets for help on using tickets.