ここの情報は古いです。ご理解頂いた上でお取り扱いください。

Opened 13 years ago

Closed 13 years ago

#2447 closed task (fixed)

サポートするPostgreSQLのバージョンを明確にする

Reported by: ebihara Owned by: ebihara
Priority: major Milestone: OpenPNE2.12.0
Component: pne-postgresql Version:
Keywords: Cc:

Description

PostgreSQL8.3以降では文字列型への自動的なキャストがおこなわれなくなったため、OpenPNEの一部SQLが正常に動作しない。

よって明示的に型変換などをおこなうことで対処する必要があるが、どのSQLに問題があるかなどを調査しなくてはならない。

そのため、セットアップガイドなどで PostgreSQL8.3 以降を現状はサポートしないことを伝えるため、PostgreSQLの対応バージョンを明確にする。

Change History (8)

comment:1 Changed 13 years ago by ebihara

Milestone: OpenPNE2.12RC1OpenPNE2.12RC2

comment:2 Changed 13 years ago by ebihara

Milestone: OpenPNE2.12RC2OpenPNE2.12.0
Owner: changed from nobody to ebihara
Status: newassigned

comment:3 Changed 13 years ago by ebihara

また、 PostgreSQL には #1694 にて取り上げられている、セットアップ用SQLのエスケープの問題などがあります。

また CentOS5.1 にてインストールすることのできる PostgreSQL のバージョンは 8.1.9 です。

これらを考慮し、

  • 7.4.x
  • 8.0.x
  • 8.1.x

を現状におけるサポート対象としたいと思います。

comment:4 Changed 13 years ago by ebihara

Keywords: 確認中 added

以下のリビジョンでセットアップガイドなどを更新しました。ご確認ください。

comment:5 Changed 13 years ago by ogawa

Keywords: 差し戻し added; 確認中 removed

8.2.x 以降に対応していないことを明記した方がよいと思います。

comment:6 Changed 13 years ago by ebihara

Keywords: 確認中 added; 差し戻し removed

以下のリビジョンで修正しました。ご確認ください。

comment:7 Changed 13 years ago by ogawa

Keywords: テスト待ち added; 確認中 removed

comment:8 Changed 13 years ago by kiwa

Keywords: テスト待ち removed
Resolution: fixed
Status: assignedclosed

実際の動作確認は行えませんが、ドキュメントの確認は問題ありませんでした。

Note: See TracTickets for help on using tickets.